Tag Archives: personal

It’s a boy!

My wife and I are expecting our second child in April. We went for  level 2 ultrasound Thursday because I was born with a clubbed foot and we wanted to make sure everything was ok with the baby.

One really Nice thing about a level 2 ultra sound is you get to find out the sex of the baby before you normally would. After a long and annoying wait at the doctor’s office because there was a scheduling mix-up we were taken to talk to the genetic counselor. We give out all of our family medical history and she makes some notes and tells us that we are at more or less no more risk than anyone else to have a child with a clubbed foot. Yay!

Next up, the ultra sound. We are eventually taken back and they start doing the ultra sound and take measurements of the baby’s head, arms, guts and pretty much every other part of the baby. We asked the lady doing the ultrasound to not tell us the sex until we could bring the rest of our family into the room. The were in the waiting room while the actual important-for-the-baby part of the ultrasound was done.

They come into the room and the ultrasound tech zeros in on the baby’s junk and announces that it is a boy. There are hugs, kisses and congratulations going around.

I’m still in shock. I know how to deal with a girls. I’m good at being a dad to Grace, now I have start at zero again. I’m excited.

Scanned Image-13

Sylvania 6842THG still broken after being repaired

I’ve posted previously about my unhappiness with Sylvania and Funai Corp in regards to the Sylvania 6842THG 42″ plasma TV I own. My level of satisfaction had done nothing but do down each and every time I have an interaction with them.

I received a phone call last week from a shipping company telling me that they had my TV and to schedule a drop off. I was excited to say the least. It had been about two months sense I had finally had it picked up for repair. I couldn’t wait to watch HD TV and play some GTA IV in HD again. 

The TV sat all boxed up at my parents house for a few days until I could stop by and pick it up to bring it home. Before I brought it home I wanted to make sure the blue / purple pixels had actually been fixed so we hooked up an Xbox with XBMC and let it run on screen saver mode for hours. Everything looked great. I didn’t see a hint of the blue / purple pixels.

Cut to today. After work today I drove over and my brother helped me load up the TV for the drive to my house. The TV made it home safe and sound. My wife couldn’t wait to have it hooked up so while she made dinner I hooked it up. HDMI to the Xbox 360, coax to the wall, original Xbox to input 1. We were set.

The first thing we watched was Terminator: The Sarah Connor Chronicles. We both thought we saw a hit or a flash of the blue or purple but not enough to really make us question it. After the show she recommended some GTA IV.

I dive right in. Driving around shooting guys. It’s great. I make a left under a bridge and the scenery goes from mostly light outside to dark inside and boom there it is. The blue / purple is back. Oh wait what is this? It is easily 10 times worse off than it was before I sent it in. This is great. I hate this tv. I hate Sylvania and Funi Corp.

I turn to my friend Google to see if I can come up with any sort of reason why this is happening other than “There is something wrong with the TV”. Some people suggest that it could be as simple as the HDMI connector causing problems. I needed to let the TV scan all the channels so I could get the digital ones back.

Once the TV is scanning channels the blue / purple goes away. It was like magic. It was there one second and gone the next. While it was scanning channels I swapped out the HDMI cable with the component cables.

Scan finishes no blue or purple. Ok so maybe it was the HDMI. Back to GTA IV. not two minutes into the game its back, just as before. I’ve taken a few pictures of it and plan to call Funi Corp or Sylvania or who ever I can get on the phone tomorrow and try to find out what exactly was done to fix my TV and what can be done about it in its current state.

A followup to WordPress 2.5 Permalink Redirect Plugin Issues

After being frustrated with the permalink redirect problems I was having last month I pretty much stopped writing anything. It was not just the permalink issues that caused me to stop it was the mad rush to get everything ready for our daughter who is now just days away from being born.

After quite a bit of putzing around with wordpress I finally gave up and used mod_rewrite to fix the urls. The changes I made can be explained like this.

If mod_rewrite is available, turn the rewrite engine on, set the rewrite base to the root of the url. The RewriteRule works like this, Any request made to this site for example this post: /2008/06/15/a-followup-to-wordpress-25-permalink-redirect-plugin-issues.html. The bolded part of the request is stored in $1 and redirected to /2008/06/15/a-followup-to-wordpress-25-permalink-redirect-plugin-issues with a 301 (moved permanently). the new request for /2008/06/15/a-followup-to-wordpress-25-permalink-redirect-plugin-issues is then handled normaly by wordpress.

That is the contents of my .htaccess file and so far it seems to be doing just what I wanted.

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^(.*).html$ /$1 [R=301,L]
</IfModule>

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

WordPress 2.5 Permalink Redirect Plugin Issues

I was just trying to convert my permalink structure from 

/%year%/%monthnum%/%day%/%postname%.html

 to 

/%year%/%monthnum%/%day%/%postname%/.

This seems like it would be a trivial thing to do with the Permalink Redirect Plugin. I followed the instructions and then was getting 404s on the old links. I don’t really have time to dig into it now but I’m guessing it has something to do with the .html in my original link structure. Maybe some regular expression issue.

I’ll take another look at it in the future. I would like to find a way to do this without manually coding mod_rewrite rules. I’m open to anyone leaving comments and I’ll be sure to post anything I find out.

Grace Elizabeth Campbell – Too cool for the womb

My wife and I went to the OB today for a scheluded appointment. My wife is 36 weeks pregnant and getting ever closer to popping like a thing of Jiffy Pop on the stove. While we were there we had it confirmed that she is measuring about 2 weeks ahead of schedule, ie she is measuring like she’s 38 weeks.

This is a good thing becuase it means we don’t have to wait as long to meet my daughter. From what I understand anything over 37 weeks is pretty much as good as full term. That being the case there really is no down side to her coming early.

This has reminded me that I need to hurry up and decide what I’m going to do on a site I bought for her when we actually decided on a name, http://www.GraceElizabethCampbell.com. Right now it has drupal 6 up and running and I think it does a fine job for displaying the few posts I have up on it.

I’ve recently been coding a plugin for WordPress to integrate the ebay EPN network so you can manage auction items in your posts. I’m leaning towards making it something like BANS but its still really early in development.

That being said, I’m really starting to like WordPress more and more. It is very good at what it does, giving you a way to post stories and posts. The admin interface, especially in 2.5 is such a pleasure to work with. Everything feels right about it. Being that it is WordPress you also get all of the other nifty plugins that other people have created, like the All in one SEO plugin and the WPG2 plugin to integrate Gallery2 into WordPress.

I suspect I’ll be making a final decision in the next week or so. I’m mostly looking for something that I can build up with her pictures and little things she does over the years.